flash required for self-install products